Forum
Welcome, Guest
Username: Password: Remember me

TOPIC: Radio LED and Horn has intermittent fault

Radio LED and Horn has intermittent fault 4 years 8 months ago #80917

  • JK
  • JK's Avatar
  • OFFLINE
  • New Member
  • Posts: 6
My 2002 cruiser has had an ongoing problem that Radio LEDb
Goes off (radio still working) and mostly the horn fails to work at the same time. We have visited several auto electricians who can cure it, the Chrysler dealer mechanic says he hasn't heard of the problem but looking online it seems a fairly common issue. However no consistent Solution is given.
Does anyone here know a reliable fix? We have already spent a few hundred dollars on this.

Thanks
The administrator has disabled public write access.

Radio LED and Horn has intermittent fault 3 years 10 months ago #81663

  • JK
  • JK's Avatar
  • OFFLINE
  • New Member
  • Posts: 6
Just an update on this. I found this is a frequent problem in US built cruisers and found the solution online in the American PT Cruiser club. I was abLe to print it out and take it to a local electrician who had been working with me on the problem for some months and get a complete fix. He had to bypass a junction box located in the steering column.
The administrator has disabled public write access.

Radio LED and Horn has intermittent fault 3 years 10 months ago #81668

  • PTmunji
  • PTmunji's Avatar
  • OFFLINE
  • Platinum Member
  • Steve & Moni
  • Posts: 1465
  • Thank you received: 48
Well done!

And thanks for posting the info regarding the solution.
Steve & Moni & her Bat-Cruiser
The administrator has disabled public write access.
10.jpg09.jpg06.jpg01.jpg02.jpg04.jpg03.jpg05.jpg11.jpg07.jpg